Certificato SSL su Aruba con WordPress

Configuriamo WordPress per l’utilizzo del Certificato SSL: da alcune settimane Aruba permette l’attivazione gratuita del certificato SSL sui domini in Hosting, ma la semplice attivazione non è sufficiente nel caso in cui sia già presente un’installazione WordPress sullo spazio web.

certificato_SSL_TLS_HTTPS_sito Continue reading

Pagine non visibili con WordPress

La Home page della vostra installazione WordPress funziona correttamente ma le altre pagine del sito non vengono visualizzate?
Se avete attivato la riscrittura degli URL, probabilmente c’è qualche problema sul file htaccess.

404-not-found-error Continue reading

WordPress e Aruba: problemi di installazione con l’Application Installer

Se avete appena installato l’applicazione WordPress su Aruba utilizzando l’Application Installer presente del pannello di controllo ma avete problemi di visualizzazione, questa piccola guida potrebbe risolvere i vostri problemi.

applicationinstaller

Il vostro dominio ha un servizio di Hosting Windows + Linux?
Se sì, il www in questo momento sta puntando al server Windows?
Potete controllarlo dal Pannello di Controllo attraverso lo strumento Gestione Host WWW.

gestione_puntamento
Se trovate la dicitura “Indirizzamento attuale: Windows” state, ovviamente, puntando al server Windows. Continue reading

Fatal error: Allowed memory size

L’errore Fatal error: Allowed memory size of 67108864 bytes exhausted compare quando viene superato il memory_limit nel PHP.

Se si ha accesso al php.ini è possibile variare il valore massimo imposto modificano la riga corrispondente:

memory_limit = 96M ; Maximum amount of memory a script may consume (64MB)

Oppure è possibile agire sul file .htaccess inserendo queste righe:

<IfModule mod_php5.c>
php_value memory_limit 196M
</IfModule>

La modifica dell’htaccess può risolvere il problema del Fatal error su diversi CMS (Prestashop, OsCommerce…), ma su WordPress possiamo agire anche in modo differente.

Se è presente un’installazione WordPress è possibile aggiungere una riga all’interno del file wp-config.php:

define('WP_MEMORY_LIMIT', '96M');

Se ad esempio avessimo un’installazione Joomla (ma possiamo inserire questo script anche in altre applicazioni) possiamo inserire all’interno del configuration.php o dell’index.php la funzione php ini_set, ovvero:

ini_set('memory_limit','96M');

Ovviamente è possibile inserire un valore qualunque 32MB, 64MB, 96MB, 128MB… ma vi ricordo che è sempre meglio ottimizzare i propri script piuttosto che aumentare indiscriminatamente il memory_limit!

WordPress e Aruba: Internal Server Error

Dopo aver effettuato l’aggiornamento di WordPress su un dominio Aruba in Hosting Linux, è possibile che riscontriate l’errore Internal Server Error.
internal-server-error

Ciò accade perchè WordPress, in fase di aggiornamento, reimposta i permessi CHMOD.
Per ripristinare quindi la corretta visibilità del sito sarà necessario accedere su Aruba al vostro Pannello di Controllo (http://admin.aruba.it), accedere nell’Area Linux a “Servizi Hosting Linux”.

strumentiarubaNella lista degli strumenti dovremo accedere alla “Riparazione dei permission” e lanciare l’operazione di ripristino.strumentiaruba2

I permessi CHMOD verranno di conseguenza reimpostati a 755 ed WordPress tornerà correttamente visibile.

Per risolvere alla radice questo problema basterà applicare una semplice modifica al file wp-config.php in modo da costringere lo script di aggiornamento a ad impostare tutti i permessi di file e cartelle a 755.
Le due righe, da inserire in una qualunque posizione all’interno del file, sono le seguenti:

define('FS_CHMOD_FILE',0755);
define('FS_CHMOD_DIR',0755);

Ricordate sempre che a seguito di un aggiornamento alcune problematiche di visualizzazione possono anche essere dovute a plugin che non funzionano più correttamente.
In questo caso basterà accedere al Back-end di WordPress e aggiornare o disabilitare i singoli plugin.

AGGIORNAMENTO 9 SETTEMBRE 2015
La versione di WordPress 4.2.X (e successive)  richiede una versione di PHP superiore alla 5.2. Pertanto, sui domini in Hosting Linux, è possibile che il messaggio di Internal Server Error sia generato anche da una non corretta impostazione della versione di PHP.
Vi suggerisco quindi si selezionare la versione 5.3 (WordPress.org consiglia la 5.4) , e verificare il funzionamento del cms.
E’ possibile variare versione di PHP accedendo al Pannello di Controllo all’indirizzo:
http://admin.aruba.it/
e seguendo il percorso:
Servizi Hosting Linux -> Scelta della versione PHP

Contact Form 7: modulo contatti per WordPress

Contact Form 7. Premettendo che sono un vecchio utilizzatore di Joomla, l’uso di WordPress mi è subito sembrato più semplice, con un back-end estremamente snello ed intuitivo. Una delle cose che mi lascia perplesso, in queste fasi iniziali di sviluppo del blog, è l’assenza, nel pacchetto XXL (che include, oltre alla ditribuzione standard, alcuni componenti più o meno utili), di un plugin che permetta di creare un modulo contatti. Continue reading